π
<-
Chat plein-écran
[^]

programme nspire

Pour le TI-Basic sur Nspire

programme nspire

Message non lude kuyio » 01 Déc 2018, 22:38

Bonsoir,
j'ai cherché un programme pour le tvi, mais les programmes présent sur le site donne la solution pour f(x)=0 et pas les autres termes. On me renseignent sur internet, j'ai trouvé un programme sur algobox, mais je ne sais pas le traduire en language ti donc je voudrai votre aide svp Merci
le voici:
1 VARIABLES
2 precision EST_DU_TYPE NOMBRE
3 borne_inferieure EST_DU_TYPE NOMBRE
4 borne_superieure EST_DU_TYPE NOMBRE
5 milieu EST_DU_TYPE NOMBRE
6 DEBUT_ALGORITHME
7 AFFICHER "Indiquer la précision désirée : "
8 LIRE precision
9 AFFICHER precision
10 AFFICHER "Indiquer la borne inférieure : "
11 LIRE borne_inferieure
12 AFFICHER borne_inferieure
13 AFFICHER "Indiquer la borne supérieure : "
14 LIRE borne_superieure
15 AFFICHER borne_superieure
16 TANT_QUE (borne_superieure-borne_inferieure>precision) FAIRE
17 DEBUT_TANT_QUE
18 milieu PREND_LA_VALEUR (borne_inferieure+borne_superieure)/2
19 SI (F1(milieu)*F1(borne_superieure)>0) ALORS
20 DEBUT_SI
21 borne_superieure PREND_LA_VALEUR milieu
22 FIN_SI
23 SINON
24 DEBUT_SINON
25 borne_inferieure PREND_LA_VALEUR milieu
26 FIN_SINON
27 FIN_TANT_QUE
28 AFFICHER borne_inferieure
29 AFFICHER " < solution < "
30 AFFICHER borne_superieure
31 FIN_ALGORITHME
Avatar de l’utilisateur
kuyio
Niveau 6: SM (Super Membre)
Niveau 6: SM (Super Membre)
Prochain niv.: 9.4%
 
Messages: 7
Inscription: 15 Nov 2018, 21:25
Genre: Non spécifié

Re: programme nspire

Message non lude Hamza.S » 02 Déc 2018, 15:24

salut,

AFFICHER c'est Disp
DEBUT_SI c'est If
TANT_QUE ... FAIRE ... FIN_TANT_QUE c'est While ... EndWhile
LIRE c'est Request
SI ... ALORS ... SINON ... FIN_SINON c'est If ... Then ... Else ... EndIf
tu oublies la ligne 17, 20, 22 et 24 elles ne servent à rien
Image
Avatar de l’utilisateur
Hamza.SAdmin.
Niveau 17: GM (Grand Maître des calculatrices)
Niveau 17: GM (Grand Maître des calculatrices)
Prochain niv.: 0.1%
 
Messages: 3195
Images: 17
Inscription: 07 Nov 2014, 00:43
Genre: Homme
Calculatrice(s):


Retourner vers Nspire-Basic

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

Campagne de dons
Pour nous aider à financer nos déplacements sur les salons/congrès qui vous donnent du contenu exclusif

Vous aurez droit aux avantages VIP et des goodies !
4.7%
-
Rechercher
-
Sujets à la une
Avantages VIP et goodies pour les donateurs !
Offre TI-Planet/Jarrety pour avoir la TI-83 Premium CE avec son chargeur pour 79,79€ port inclus !
Offre TI-Planet/Jarrety pour avoir la TI-Nspire CX CAS à seulement 130€ TTC port inclus!
Jailbreake ta TI-Nspire avec Ndless et profite des meilleurs jeux et applications !
1234
-
Faire un don / Premium
Pour plus de concours, de lots, de tests, nous aider à payer le serveur et les domaines...

Découvrez les avantages d'un compte donateur !
JoinRejoignez the donors and/or premium!les donateurs et/ou premium !


Partenaires et pub
Notre partenaire Jarrety 
-
Stats.
345 utilisateurs:
>317 invités
>23 membres
>5 robots
Record simultané (sur 6 mois):
6892 utilisateurs (le 07/06/2017)
-
Autres sites intéressants
Texas Instruments Education
Global | France
 (English / Français)
Banque de programmes TI
ticalc.org
 (English)
La communauté TI-82
tout82.free.fr
 (Français)