Page 1 of 17

[FR/EN] Downgrade Nspire OS 3.9 CX / ClickPad

Unread postPosted: 02 Nov 2014, 21:54
by critor


Ce tutoriel vous permet de downgrader votre
TI-Nspire CX
ou
TI-Nspire ClickPad
(
CAS
ou
non-CAS
), c'est-à-dire de forcer l'installation d'une version antérieure compatible.

Il cible les calculatrices disposant des OS suivants ou capables de les installer :
  • OS CX non-CAS 3.9.0.461, 3.9.0.463, 3.9.1.38
  • OS CX CAS 3.9.0.461, 3.9.0.463, 3.9.1.38
  • OS ClickPad non-CAS 3.9.0.461, 3.9.0.463
  • OS ClickPad CAS 3.9.0.461, 3.9.0.463
Les TI-Nspire TouchPad monochromes ne sont pas supportées pour le moment.


Pour vérifier votre version d'OS actuelle, tapez :nsho: :ns5: :ns4:.


Version d'OS minimale compatible installable et utilisable en fin de tutoriel
:
This tutorial will let you downgrade your TI-Nspire CX or TI-Nspire ClickPad (CAS or non-CAS) to any older compatible version.

It targets the calculators running the following OSes or able to install them :
  • CX non-CAS OS 3.9.0.461, 3.9.0.463, 3.9.1.38
  • CX CAS OS 3.9.0.461, 3.9.0.463, 3.9.1.38
  • ClickPad non-CAS OS 3.9.0.461, 3.9.0.463
  • ClickPad CAS OS 3.9.0.461, 3.9.0.463
Monochrome TI-Nspire TouchPad are not supported for the moment.


To check your current OS version, type :nsho: :ns5: :ns4:.


Miniminal compatible & installable OS version at the end of the tutorial
:
ClickPad
CX
Boot2=3.9.1.34
Boot2<3.9.1.34
HW-S+
HW J-R
HW-J+
HW A-I
1.1
3.9.1
3.6
3.2.3
3.0

Vérifiez la révision matérielle de votre calculatrice CX
(dernière lettre du code P-0000X gravé au dos à droite du numéro de série)
.
Exemple de photo d'une révision matérielle CX J ci-contre.

Si votre révision matérielle CX est 'S' ou une lettre supérieure, votre calculatrice ne fonctionnera pas correctement avec un OS < 3.9.1, ce qui rend l'application de ce tutoriel totalement inutile. Mais peut-être que Ndless 3.9 pourra vous permettre de réaliser ce que vous vouliez...
Si votre révision matérielle CX est 'J' à 'R', seules les versions d'OS 3.2.3 et supérieures sont compatibles.
Check your CX calculator hardware revision
(last letter from the P-0000X code written on the back at the right of the serial number)

Photo showing a CX hardware revision J on the right.

If your CX hardware revision is 'S' or above, your calculator will not work correctly with OS <3.9.1, making the downgrade useless. But maybe Ndless 3.9 can be used instead for what you're trying to achieve...
If your CX hardware revision is 'J' to 'R', only OS versions 3.2.3 and later are compatible.

Le tutoriel
:

  1. Installation de l'OS 3.9:
    (sautez si déjà fait)

    Téléchargez l'un des fichiers suivants et envoyez-le sur la calculatrice:
  2. Installez DowngradeFix 3.9:
    • Téléchargez DowngradeFix 3.9: archives_voir.php?id=105677
    • Extrayez le contenu de l'archive
    • Selon votre version d'OS, envoyez sur la calculatrice le fichier 'downgradefix390cl.tns' pour une TI-Nspire ClickPad, 'downgradefix390cx.tns' ou 'downgradefix391cx.tns' pour une TI-Nspire CX.
  3. Déconnectez la prise USB.
  4. Sur la calculatrice, ouvrez le fichier reçu.
    Vous devriez être invité à reconnecter la prise USB.

    Image
  5. Reconnectez la prise USB.
    Un message devrait maintenant vous informer que la protection anti-downgrade a été désactivée.

    Image
  6. Téléchargez et installez maintenant l'OS 3.6 :
  7. Si l'USB ne semble plus fonctionner correctement, vous empêchant d'installer l'OS 3.6, il y a 2 solutions possibles (testez les 2 si l'une ne marche pas) :
    • Enfoncez 'reset' au dos de la calculatrice pour la redémarrer et reprenez à l'étape 3. (Peut marcher... ou non - dans ce cas, cf. 2ème solution)
    • Une fois le message de downgrade en haut à gauche affiché, allez dans le menu de maintenance (faites un reset (bouton au dos), en restant appuyé sur :nsdo: :nsen: :nsee:, jusqu'à arriver au menu de maintenance). Ensuite, désinstallez l'OS. Après le redémarrage, transférez/installez l'OS 3.6.
  8. Si vous arrivez, après un redémarrage, au menu de Diagnostics, vous avez juste besoin d'aller dans "0. Additional function", puis "Go to OS mode" et de redémarrer/reset la Nspire (bouton au dos) encore la calculatrice.
  9. Une fois l'OS 3.6 installé, si vous souhaitez installer une version d'OS antérieure à la 3.6, suivez le tutoriel de downgrade OS 3.6.
The tutorial
:

  1. Install OS 3.9:
    (skip if already done)

    Download one of the following files and send it to the calculator:
  2. Install DowngradeFix 3.9:
    • Download DowngradeFix 3.9: archives_voir.php?id=105677
    • Extract the archive content.
    • Depending upon your OS version, send to the calculator 'downgradefix390cl.tns' for a TI-Nspire ClickPad, 'downgradefix390cx.tns' or 'downgradefix391cx.tns' for a TI-Nspire CX.
  3. Disconnect the USB plug.
  4. On the calculator, open the received file.
    It should invite you to reconnect the USB plug.

    Image
  5. Reconnect the USB plug.
    It should now tell you the downgrade protection has been disabled.

    Image
  6. Now download OS 3.6 and send it to the calculator :
  7. If the USB doesn't seem to be working properly anymore, preventing you from sending OS 3.6, there are 2 possible solutions (try both if the first doesn't seem to work):
    • Press 'reset' on the back to reboot the calculator and go back to step 3. (may work... or not. In such case, look at the solution #2)
    • Once the downgrade message is displayed on the top left, go to the maintenance menu (reset the calc (button on the back), and/while keep pressing :nsdo: :nsen: :nsee: until you reach the maintenance menu). Then uninstall the OS. After the reboot, just transfer/install the OS 3.6.
  8. You may get to the Diagnostics menu. If that's the case, you just need to go to "0. Additional function", then "Go to OS mode" and then reset the calculator again.
  9. Once OS 3.6 has been installed, if you want to install an OS version older than 3.6, now proceed to the "Downgrade OS 3.6" tutorial
    .

Re: [FR/EN] Downgrade OS 3.9 CX

Unread postPosted: 02 Nov 2014, 21:57
by pierrotdu18
Génial !! :D
Et elle est super l'animation :)

Re: [FR/EN] Downgrade OS 3.9 CX

Unread postPosted: 02 Nov 2014, 22:02
by QuanticPotato
Woaww ! Beau boulot ! :)

Re: [FR/EN] Downgrade OS 3.9 CX

Unread postPosted: 02 Nov 2014, 22:22
by pierrotdu18
Elle sert à quoi la deuxième page avec la question et le point "A" ? :D

Re: [FR/EN] Downgrade OS 3.9 CX

Unread postPosted: 03 Nov 2014, 00:20
by Adriweb
C'est du QnA Lua (Lua débridé avec d'autres APIs, non publics, mais qui ne sont pas utiles pour 99% des gens qui codent en Lua, du moins depuis la 3.6), et tu as bidouillé sur TINCS si tu vois ca, ce qui ne t'amènera nul part anyway :D

Re: [FR/EN] Downgrade OS 3.9 CX

Unread postPosted: 03 Nov 2014, 00:23
by pierrotdu18
Ah ah :D
Bah ouais mais il y quand même 6000 lignes de code et une implémentation d'un GUI qui a l'air vachement organisé, donc je me demandais ce que ça pouvait bien être...
Et pour avoir ce Lua débridé, il faut trafiquer le .tns j'imagine non ? ;)

Re: [FR/EN] Downgrade OS 3.9 CX

Unread postPosted: 03 Nov 2014, 02:40
by Adriweb
Rajouté la 7ème étape, utile pour certaines calculatrices seulement.

Re: [FR/EN] Downgrade Nspire OS 3.9 CX / CX CAS

Unread postPosted: 03 Nov 2014, 03:09
by ruatmap
Cet outil ne fonctionne pas avec mon TI-Nspire CAS touchpad

Re: [FR/EN] Downgrade Nspire OS 3.9 CX / CX CAS

Unread postPosted: 03 Nov 2014, 03:11
by Adriweb
ruatmap wrote:Cet outil ne fonctionne pas avec mon TI-Nspire CAS touchpad

Oui, comme précisé plusieurs fois...
CX/ CX CAS seulement,
pour le moment
du moins.

Re: [FR/EN] Downgrade Nspire OS 3.9 CX / CX CAS

Unread postPosted: 03 Nov 2014, 03:31
by critor
Adriweb wrote:Oui, comme précisé plusieurs fois...
CX/ CX CAS seulement,
pour le moment
du moins.


Non, tu n'as pas bien compris le problème.
Le reboot après l'installation de l'OS 3.6 ne pose aucun problème jusqu'à preuve du contraire.

C'est juste après l'exécution du DowngradeFix, que la calculatrice peut être laissée dans un état instable empêchant la communication USB, état nécessitant donc un reboot.
Et il semble que dans ce cas-là, le logiciel de Diagnostics se lance - j'ignore pourquoi d'ailleurs puisque le code ne touche pas à ce drapeau.